What version of mac OSX do I need for nookStudy?

Believe it or not you need Snow Leopard. B&N claims nookStudy is so advanced it needs the 10.6 libraries.  Amazing people have been using sophisticated apps like HD movie editing, Music mixing, and advanced photo editing tools all these years eh?